Unable to create a task from a task form via API

I created a task form without questions in order to have all of the custom attributes added to a task upon creating a task. However, via postman collection and python/API, I am unable to create a task from an task form. The only error I get back is “Please provide a correct ‘app-workspaceid’ header. API users, please provide a correct api-key header and the Authorization: api-key header”.

I added ‘app-workspaceid’ to the header record with the correct value however now I just get a 401 error. I have validated that task form is live and I even tried making the form public and still no success. Yes, the api-key has access should have access to all height functionality.

Any guidance would be appreciated.

Oof, thanks for flagging, Steven! Will have our team take a look and circle back!

Hi Steven! Height developer here.

For API usage you’ll need to provide the key in the Authorization header, for example:

curl https://api.height.app/workspace \
  -H "Authorization: api-key secret_1234" 

API docs for reference: https://www.notion.so/height/API-documentation-643aea5bf01742de9232e5971cb4afda?pvs=4#378bc94823fe47abb2b227f0a7f3c67c

Let me know if that still doesn’t work and I can take a further look.


To clarify my earlier statement:
By adding the workspace id to the header meant that I had both the api-key and the workspace id as a part of the header. Postman is still reporting an invalid error stating that is an auth issue when something else is not quite correct.

If you can provide a working example of using a task form to create tasks using the API, that would be helpful.

You don’t need to include the workspace ID in the header - just the api key.

In postman the configuration should look something like this:

The error message coming from Height is that I need to include the workspace ID when trying to create a task from a task form. When receiving that error message, what is Height expecting?

To clarify, is this a new error, or are you referring to the one you mentioned in the original post? If you can provide a screenshot or paste a snippet of what you’re sending to the API that might help.